900 stopped working after 2 uses

648 Views 2 replies
Wendi H.
Joined: 2/10/2014

I just received my 900 last week, made two somewhat successful Blasts over the weekend (still in a learning curve), went to make one yesterday morning, and it would only give a short pulse, and that was it.  I plugged and unplugged, tapped, shook, etc. I had even made it under the Max line since I had a problem my frist try with over filling.  I thought it was the Superfood jamming up the blades, so I didn't use anything but fruit and spinach this morning, but it did the same thing.  Has anyone else had this problem?

Please contact Customer Service so they can help you troubleshoot. 1-855-346-8874.
doeeyes67 wrote:

I just received my 900 last week, made two somewhat successful Blasts over the weekend (still in a learning curve), went to make one yesterday morning, and it would only give a short pulse, and that was it.  I plugged and unplugged, tapped, shook, etc. I had even made it under the Max line since I had a problem my frist try with over filling.  I thought it was the Superfood jamming up the blades, so I didn't use anything but fruit and spinach this morning, but it did the same thing.  Has anyone else had this problem?

My husband and I purchased a 900. after a few blasts,it stopped working . The last blast when we removed the cup the motor was still running. As it had only been a couple of days from purchase we returned it to bb&b. They replaced it with no problems. THey were extremely nice. So far so good. We also had the 600 , we loved it. We were really surprised when we had to return the 900.